Blog Andri Wiratmono

Pagut Asri Blok D No.2 - Kelurahan Blabak - Pesantren Kota Kediri

back

Mikrotik Whatsapp Notifikasi

25 Januari 2021 || 09:37:52 WIB || ClassyID

Catatan ini sebagai arsip pribadi, biar tidak lupa, script aselinya kita ambil dari labkom, kita modifikasi sedikit sesuai keperluan.

Dalam membuat notifikasi whatsapp ini, sebenarnya sama persis jika kita memakai bot telegram, beda nya ini kita harus punya WA Server.

WA Server akan kita bahas di lain waktu.

Whatsapp API Server yg kita gunakan, juga sudah pernah saya tulis di blog ini.

Oke kita mulai, Whatsapp Notifikasi Mikrotik bisa digunakan buat informasi apapun yg ada di mikrotik, disini saya batasi dengan 2 tool, yaitu kita memakai Netwatch dan Memakai Scheduler Script.

Pertama Memakai Netwatch, ini fungsinya hanya memberikan notifikasi bahwa ada jaringan yg putus/nyambung.

Hasil seperti screenshoot dibawah ini

Nah ini scriptnya hanya seperti ini : 

:local idrouter [/system identity get name];
:local idtime [/system clock get time];
:local iddate [/system clock get date];
/tool fetch url="https://kirimwa.classy.id/kirimwa.php?pesan=*PING*%20Wifi.Pak.Wendy%20*TERSAMBUNG*%0AMelalui%20Router%20*$idrouter*%0ADikirim%20$iddate%20$idtime%0D%0A%0D%0A*_Log_*%3A%0D%0A_Pesan_+_ini_+_dikirim_+_otomatis_%2C+_ketika_+_wifi_+_terdeteksi_+_tersambung_+_atau_+_terputus_%2C+_Sebagai_+_layanan_+_informasi_+_pelanggan_+_dari_+*PagutAsri-NET*&handphone=6285648811419" keep-result=no;
 

Script ini dipasang di tab UP dan DOWN, tinggal dirubah kata2nya, ketika down atau ketika up

Link WA Servernya ini : https://kirimwa.classy.id/kirimwa.php , silahkan digunakan FREE, insya allah online 24 jam

Kedua, kita bahas pembuatan informasi penggunaan traffik internet menggunakan scheduler dan script.

Hasil seperti screenshoot dibawah ini

Kebetulan topologi yg digunakan seperti ini

WMS - > Mikrotik - > Client

Mikrotik yg digunakan seri RB2011 yg mempunyai 10 ether

Client disini masuk ke ether 2,3,4,5,6,7,8,10

Jadi disini kita melihat informasi melalui interface, bisa juga berdasarkan IP (lewat mangle) nanti lain waktu kita bahas.

Alur Info Trafik Datanya sperti ini :

1. Schedululer (bs tiap detik/menit/jam) -> 2. Script (memperoleh data dari scheduler) untuk diproses sbg informasi -> 3. Scheduler pengiriman pesan

Kita buat scheduler untuk Trafik UP (upload) :

:local namaINT "ether2";
:local tx [/interface get value-name="tx-byte" [find name="$namaINT"]];
:local txMB ($tx / 1024 / 1024 );
/system sche set comment=$txMB [find name="TRAFIK-UP-ROLI"]

untuk yg DOWNLOAD ini :

:local namaINT "ether2";
:local rx [/interface get value-name="rx-byte" [find name="$namaINT"]];
:local rxMB ($rx / 1024 / 1024  );
/system sche set comment=$rxMB [find name="TRAFIK-DOWN-ROLI"]

bedanya di $rx dan $tx

Scheduler diatas dijalankan tiap 1 jam, utk test disarankan memakai 5-10 detik, agar lebih cepat, jika scriptnya sudah jalan, baru kita setting sesuai kebutuhan.

Selanjutnya membuat script 

:local idtime [/system clock get time];
:local iddate [/system clock get date];
:local idrouter [/system identity get name];
:local idipku [/ip cloud get public-address];
:local iduptime [/system resource get uptime];
:local totalUP [/system sche get [find name="TRAFIK-UP-ROLI"] comment];
:local totalDOWN [/system sche get [find name="TRAFIK-DOWN-ROLI"] comment];
:local total ($totalUP + $totalDOWN);
/tool fetch url="https://kirimwa.classy.id/kirimwa.php?pesan=*INFO*+Pemakaian+Internet%0D%0A*Bapak.Ruli*%0D%0A$iddate%0D%0A%0D%0ADOWNLOAD%3A+$totalUP+MiB%0D%0AUPLOAD%3A+$totalDOWN+MiB%0D%0A*TOTAL*%3A+*$total*+*MiB*%0D%0A%0D%0ADikirim%3A+$idtime%0D%0AOleh%3A+Notifikasi.Whatsapp%0D%0A%0D%0A*_Log_*%3A%0D%0A_Pesan_+_ini_+_dikirim_+_otomatis_%2C+_tiap_+_hari_+_setiap_+_pukul_+_23.50_+_WIB_%2C+_Sebagai_+_layanan_+_informasi_+_pelanggan_+_dari_+*PagutAsri-NET*&handphone=62885648811419" keep-result=no;
}

Setelah itu tinggal membuat scheduler lagi untuk menjalankan script tadi, kapan informasi ini dikirim.

Jika ada yg ingin mikrotiknya dibuatkan seperti ini bisa kontak di wa.me/6285648811419