Blog Classy Indonesia Mandiri

Catatan seorang Andri Wiratmono

back

TERBARU CARA KIRIM PESAN WHATSAPP DARI MIKROTIK ROUTER

09 Juli 2022 || 22:36:52 WIB || ClassyID

Untuk bisa membuat notifikasi dari Mikrotik Router ke Whatsapp, dibutuhkan yang namanya whatsapp gateway, saat ini banyak sekali penyedia whatsapp gateway, salah satunya dari Classy Indonesia Mandiri

Contoh Screenshoot notifikasi seperti ini 

Berikut ini langkah² sebagai catatan pribadi saja

Login ke Aplikasi Whatsapp Gateway

Masukkan Username dan Password

Didapatkan dengan menghubungi Kami 

Setelah berhasil login, masuk ke halaman dashboard

Klik Tombol Add Device

Masukkan Nomer Whatsapp Anda

Jika sudah berhasil, klik tombol qrcode seperti gambar 2 screenshoot diatas ini

Setelah itu akan muncul qrcode, seperti web whatsapp

Scan QRCODE ini melalui HP, tunggu kurang lebih 1-2 menitan, sampai di HP berstatus konek

Tunggu sampai HP sampai connected

Jika QRCODE yang discan berhasil, maka sistem di Aplikasi ini akan muncul seperti gambar dibawah ini

Ini Artinya HP Whatsapp dan APlikasi Whatsapp Gateway sudah terhubung

Selanjutnya kita test kirim pesan yaaa

Masuk ke menu Message Test, Pilih Text, Isi sender sesuai yang diinput, Ketik nomer tujuan, bisa diawali 0 atau 62, isi pesan, setelah itu klik Send

Jika di HP Whatsapp sudah muncul pesan yg sama, maka test kirim pesan berhasil

Selanjutnya kita ke Menu Setting untuk Melihat API KEY, API Key ini berfungsi menghubungkan Aplikasi Lain agar bisa mengirim pesan whatsapp

Silahkan dicopas API KEYnya di notepad

Sekarang kita buka Winbox Mikrotik kita

Copas Script ini ke System > Script

:local idtime [/system clock get time];
:local iddate [/system clock get date];
:local idrouter [/system identity get name];
:local iduptime [/system resource get uptime];
:local idcpuload [/system resource get cpu-load];
:local number "08564881xx";
:local sender "6285648811xx";
:local apikey "IpJA9aQWiR6nYgcqxxxxxx";
:local wagateway "https://xxx.classy.id/send-message";
:local message "*$iddate*%20*$idtime*%0A*INFO*%20_$idrouter_%0A%0A_Log_%0AIPV4:%20_$idipku_%0ADNS:%20_$iddnsku_%0ACPU-LOAD:%20_$idcpuload_%20%%0AUPTIME:%20_$iduptime_";
:tool fetch mode=http http-header-field="Content-Type: application/x-www-form-urlencoded; charset=UTF-8,User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36," http-method=post http-data="api_key=$apikey&sender=$sender&number=$number&message=$message" url=$wagateway;

Sesuaikan number, sender, apikey, message sesuai kebutuhan anda, hasil dari script ini seperti screenshoot paling atas

Semoga informasi ini berguna

Jika informasi ini berguna silahkan share, dan jika butuh whatsapp gateway silahkan kontak kita ya KLIK DISINI